System requirements

Operating system: Linux kernel 2.6 or newer

Processor: Intel Pentium or newer

Memory: 32 MB or more

Available hard drive space required for installation: less than 5 MB

The program is completely vendor-independent and is compatible with all PCs. As far as the available functions are concerned, it is irrelevant if we run AIDA64 on a server or client operating system.

Further requirements:

  • lshw package version is B.02.16 or later
  • libc6 libraries (recommended)
  • root credentials for running the program (recommended)
  • iconv package (language-dependent)

If we need complete reports, we must run the program with root privileges. When run with lower credentials, the application does not have access to all hardware and software information, and, as a result, it can only create incomplete reports with notably fewer details.

The static version of the program contains most of the required libc6 libraries, but we only recommend using this on servers where libc6 installation is not possible.